1. Do you need support for Assetto Corsa Competizione? Please use the proper forum below and ALWAYS zip and attach the WHOLE "Logs" folder in your c:\users\*youruser*\AppData\Local\AC2\Saved. The "AppData" folder is hidden by default, check "Hidden items" in your Windows view properties. If you report a crash, ALWAYS zip and attach the WHOLE "Crashes" folder in the same directory.
  2. FOR ASSETTO CORSA COMPETIZIONE: If you report issues with saved games, please always zip and attach your entire User/Documents/Assetto Corsa Competizione/Savegame folder!
  3. If your game executable is missing, please add your entire Steam directory to the exceptions in your antivirus software, then run a Steam integrity check or reinstall the game altogether.

gpu frame time "pulse"

Discussion in 'ACC Hardware Discussions' started by georgi iovchev, Jun 13, 2020.

  1. edit: Finally discovered that the issue is caused from sim dashboard app. Reported and it seems to be fixed in simdash latest beta 3.3.0.0

    Sometimes I notice that the frame time is pulsing. (See the attached image). And this pulse is the same no matter if I am driving or staying on pause.

    upload_2020-6-13_23-11-6.png

    I have limited the gpu max frame to 138, and is holding stable. But the frame time is pulsing 7-8ms.

    It's a hotlap single player session. I have tried some things to get the line straight - quitting all background apps (mainly telemetry) and services, switching full screen off and on, reverting to default gpu clocks (MSI afterburner), applying oc profile again - no change. And the only fix is to quit the session (not the game), and start it again - then the frametime graph is completely straight line :)

    Actually there is no stuttering or anything similar when driving. It's just interesting how that happens - looks like a perfect cardiogram :)
     
    Last edited: Sep 5, 2020

  2. Similar Threads
    Forum Title Date
    Troubleshooting - Workarounds Oculus Rift: low GPU usage - low framerate Jul 15, 2017
    Chit Chat Room GTX 1080ti. Is this GPU good enough to use with the RIFT without losing frames? Apr 19, 2017
    Graphics and Models/Tracks Bugs & Issues Gpu usage 99% ever and bad frame rate v1.3 Oct 8, 2015
    ACC Hardware Discussions RTX 3080 GPU + Ryzen 5000 CPU = Minimum 80-90FPS on HP Reverb G2 Oct 1, 2020
    ACC Troubleshooting UE4 crash [GPU driver hung] Jul 26, 2020
    ACC Troubleshooting GPU-Usage level very low Jul 25, 2020
    ACC Troubleshooting ue4-ac2 [GPU driver hung] Jul 24, 2020
    ACC Graphics - Tracks and Cars 80fps and 60% GPU Usage Jul 19, 2020
    ACC Troubleshooting Timed out while waiting for GPU to catch up. Jul 5, 2020
    Chit Chat Room Suggested CPU & GPU Jun 30, 2020
    ACC Troubleshooting Game crashes [GPU driver crash] May 4, 2020
    ACC Troubleshooting Same crash happens randomly [GPU drivers crash] Apr 20, 2020
    Troubleshooting - Workarounds ac crash, freeze pc and overheat gpu Mar 21, 2020
    ACC Troubleshooting Gpu usage Feb 23, 2020
    ACC Troubleshooting game is crashing to desk top all the time [GPU driver rollback] Feb 7, 2020

  3. AndyK70

    AndyK70 Simracer

    138fps equals 7.2463768115942ms each frame, wouldn't surprise me if this "pulse" is a display error in rounding. Not a RTSS fault but an inevitable problem for floating point numbers stored in a binary system.

    Would be interesting to see if it still pulses limiting it to 125fps (8.0ms).

    When entering Framerate limit as fps RTSS take it, converts it to microseconds per frame and then knows when to limit frames and for how long.
    If you want more than 125fps with somewhat "clean" time limit you can try this:
    In RTSS after selecting the game profile you could also click on the Label "Framerate limit" which is a button and switch it to "Frametime limit". Then enter the limit in microseconds (1,000,000 = 1s).
    For example 7250 is 7.25 milliseconds for each frame which results in 137.921 fps, or 7500 for 133.33 fps
     
  4. I dont have profile in rtss for ACC.
    I was limiting the fps from the game video settings. But you are right, I will try your suggestion next time this pulsation happen.

    Actually what would be the better option .. in terms of less lag. To leave the game unlimited and limit using rtss or to use the ingame limit?

    Thanks
     
  5. AndyK70

    AndyK70 Simracer

    It's not really a fps shooter, so I don't know, if it really plays a huge role in ACC, but from what I've read by other users of MSI AB and RTSS they always prefer RTSS limiting than ingame for lower input lag.
     
  6. moeppling

    moeppling Gamer

    I've got huge stutter/frametime issues when using the ingame fps limiter. Especially after tabbing out at least once. Using the driver fps limit (nvidia) solved that.

    Use the nvidia/amd limiter over rtss for reduced input lag. Use the rtss limiter as a last resort.
     
  7. Thanks, I'll keep this in mind. Actually this pulsing happens rarely and it is most likely because sometimes i do alt-tab to see something on the desktop.
     
    Last edited: Jun 15, 2020
  8. Krassmus

    Krassmus Gamer

    Is vsync active? (Nvidia or in game? Or are you using borderless mode so windows aero vsync might be active?)
    If yes and you have a 144 hz monitor, this frame time pulsing might be due to the limit being below your refresh rate.
    This reduces the input lag because it keeps the frame buffer from getting full.
    It starts almost full but due to less frames being allowed than needed for vsync, it slowly goes empty and when it is really empty, one frame will be displayed twice, which causes a slight micro stutter.

    This micro stutter is not really noticeable at 144 hz though as it's very very short.

    All fps monitoring tools I know sadly only show an average. So instead of seeing 30/60/30/60 when you'd limit to 45 fps with 60 hz vsync, you'll see 45 fps in the monitoring tools.

    However you might see a little bump in the graph when the above mentioning empty frame buffer happens.

    About fps limiters:

    Blurbusters have measured the input lag for Nvidia inspector (the new version is now visible for everyone in the control panel).
    It's a lot higher than the lag induced by rtss.

    That's due to nvidia's fps limiter locking the gpu from rendering more frames in advance but not the cpu. So the gpu will get "old" / "cached" frames.

    Rtss hooks into the cpu step of rendering so the cpu won't calculate too many frames.
    It induces "up to 1 frame of lag" though, since once frames is needed to be cached for a consistent frame time.

    The only fps limiter that could in theory be better is the in game limiter. Depending on how well it is working, it could stop the game itself from giving the cpu more frames than needed but sadly a lot of in game limiters are pretty bad.

    So I always use rtss as I don't have to fiddle with the game or with the input lag from the Nvidia limiter.
    It always works in the same, consistent way with a very low input lag.
     
    Last edited: Jun 16, 2020
    AndyK70 and georgi iovchev like this.


  9. yes, if ingame frame rate limiter is good - it's best to use it :)
     
    AndyK70 and Krassmus like this.
  10. PowderGuy

    PowderGuy Rookie

    I have a rental PC using 2070 with full Epic graphics and Full Grid. Have a FPS pulse like you.
    My experience reduce a bit Mirror resolution to solve.

    Also, CPU processing AI movement would case this issue too.
     
  11. Yes in case cpu or gpu usage is high probably it would be normal to have uneven frametime.
    But in my case I dont have AIs, and have plenty of spare gpu and cpu power.
    Yesterday it happened again. I have left the car in garage (without leaving the session) and went out to smoke a cigarette and when I returned I saw the pulses.
    I experimented and without leaving the session again, I removed the ingame frame limit and set the limit in the RTSS and got perfect straight frametime line.
     
    AndyK70 likes this.
  12. f.e.negroni

    f.e.negroni Racer

    The video above covers it really well I think:
    RTSS and now even the NVIDIA CP setting introduce around 1 frame delay and provide the best frametime pacing, because they buffer the frame and deliver it at the exact time.
    In game fps limiters will instead run within the game, introduce no delay, but can deliver slightly variable frametime pacing.
    The question I have is: can you actually notice, while gaming, that your frame pacing is incorrect?
    Another question: what did you select in the Nvidia (or AMD equivalent) Latency setting? I believe Kunos pointed out that having Low or Ultra Low selected is bad for the game framepacing.
     
  13. As I said in my opening post - I dont notice it during the gameplay. I would never know that there is pulsing if I dont have the graph on the osd.

    In nvidia control panel low latency mode is default value off - globally and acc profile uses the global value.
     
    f.e.negroni likes this.
  14. Krassmus

    Krassmus Gamer

    Can you tell us, just out of interested what kind of monitor you are using?
    What is the refresh rate (hz) of it and are you using vsync or gsync or no sync at all?

    Also you didn't answer to me if you're using full screen or borderless :p
     
  15. I use full screen (had also tried borderless - it does not fix the pulse)
    My monitor is Samsung 39:9 3840x1080, 144hz, vsync is off, i dont have enabled gsync/freesync.
     
    Krassmus likes this.
  16. f.e.negroni

    f.e.negroni Racer

    Maybe the last thing to try is true full screen: right click on the ac2 executable and disable full screen optimisation. The overlay for frame time should still work.
     
    georgi iovchev likes this.
  17. Hmm good idea, thanks. Next time I see the cardiogram I will try that.
     
  18. This evening I played with the full screen optimizations disabled on the ac2.exe and the same pulsing happened again after a hour or something .. the same scenario - i left the pc for a while and when i returned frametime graph was pulsing, but this time with higher peaks.
     
  19. Krassmus

    Krassmus Gamer

    All rtss limiting, full screen optimizations etc need to be applied to the ac2-win64-shipping.exe or whatever it's called exactly.
    You should find it deeper inside the game's steam folder.
    The ac2.exe is just a launcher or something...
     
  20. yes, yes that is what i did, but it was just too long to type D:\Games\Steam\steamapps\common\Assetto Corsa Competizione\AC2\Binaries\Win64\AC2-Win64-Shipping.exe :)
     
    Krassmus and f.e.negroni like this.
  21. f.e.negroni

    f.e.negroni Racer

    The interesting question to ask would be ‘are other unreal engine 4 games suffering the same issue?’
    The frame limiter is a built in unreal engine component. Therefore if there’s a bug that would affect all other games built with the same version. unless in ACC they do something that interferes with it. Or maybe it’s like that by design.
    you say after one hour right?
    You use afterburner? I’ll have a try.
     
    georgi iovchev likes this.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice