1. Do you need support for Assetto Corsa Competizione? Please use the proper forum below and ALWAYS zip and attach the WHOLE "Logs" folder in your c:\users\*youruser*\AppData\Local\AC2\Saved. The "AppData" folder is hidden by default, check "Hidden items" in your Windows view properties. If you report a crash, ALWAYS zip and attach the WHOLE "Crashes" folder in the same directory.
  2. FOR ASSETTO CORSA COMPETIZIONE: If you report issues with saved games, please always zip and attach your entire User/Documents/Assetto Corsa Competizione/Savegame folder!
  3. If your game executable is missing, please add your entire Steam directory to the exceptions in your antivirus software, then run a Steam integrity check or reinstall the game altogether.

Input lag

Discussion in 'ACC Hardware Discussions' started by unknwn, Aug 11, 2019.

  1. unknwn

    unknwn Alien

    Apparently UE has console command called "r.OneFrameThreadLag" which reminds of Nvidia "Maximum pre-rendered frames" setting. You can see full list of UE4 commands with descriptions in command library (click here).

    r.OneFrameThreadLag:
    ACC appears to have this value ON by default (allow 1 frame lag).

    ACC game performance comparison with "r.OneFrameThreadLag" value on/off below.
    ON (or no value set at all):
    200 FPS - no AI
    75 FPS - 29 AI
    OFF:
    164 FPS - no AI
    56 FPS - 29 AI

    Tested on AMD 2700x CPU, HIGH graphics preset (to increase CPU load) but with 720p remove GPU bottleneck.

    Performance results are the same regardless whether Maximum pre-rendered frames is set to 1 in Nvidia CP which probably indicates that NV cannot override this UE value.

    Looking at performance levels it looks like the value actually works, however the important question is whether there is a noticeable input lag reduction as the performance price is quite high (especially with AI where CPU load is much higher).

    It would be interesting that more people could test this UE setting especially if someone has a high FPS camera to compare a input lag.
     
    Last edited: Aug 11, 2019
    dek, Shooter80, LeDude83 and 4 others like this.

  2. Similar Threads
    Forum Title Date
    ACC Troubleshooting Input lag in quick race but not practice / hotlap Oct 6, 2018
    ACC Controls & Peripherals Input lag at high fps, no vsync. Sep 13, 2018
    ACC Gameplay Input lag Sep 13, 2018
    Controllers and Peripherals Bugs & Issues Fanatec GT3RS v2 input lag Apr 25, 2017
    Controllers and Peripherals Bugs & Issues CSW V2, fanatec f1 rim INPUT LAG/DELAY gear and lights Mar 23, 2017
    Controllers and Peripherals Bugs & Issues Microsoft sidewinder input lag Mar 1, 2017
    Chit Chat Room Project : minimizing input lag Part2 (AMD 470). Jan 6, 2017
    Chit Chat Room The quest for no jitter or input lag Sep 22, 2016
    Chit Chat Room Input lag, a way to measure? Aug 30, 2016
    Troubleshooting - Workarounds Minimizing input lag in triple screen? Jul 20, 2016
    Chit Chat Room Project : minimizing input lag Feb 13, 2016
    Controllers and Peripherals Bugs & Issues Input lag? or not? Jan 9, 2016
    Chit Chat Room Pre rendered frames (input lag reduction) Aug 19, 2015
    Troubleshooting - Workarounds Excessive input lag with v-sync Jun 15, 2015
    Chit Chat Room Does input-lag make driving/drifting easier? Apr 30, 2015

  3. Coanda

    Coanda Alien

    Interesting. I have always set the RHI.MaximumFrameLatency=1 in the engine.ini. What is strange is r.OneFrameThreadLag is not showing in the log file with all the other rendering UE4 commands. Good find :)
     
    Shooter80 and After_Midnight like this.
  4. Coanda

    Coanda Alien

    It is FPS taxing. With it off in SP I was 10-25 FPS lower. What I did notice though even though I had less FPS, my milliseconds per frame went up by 2-3. I thought this would be the other way around...
     
  5. unknwn

    unknwn Alien

    If you have less FPS then your frame time will be higher. Frame time shows how long it takes to render a frame, however it doesn't take into account whether the frame rendering was delayed or not.
    Ideally to see whether this setting has influence on the input latency you should test it with same FPS (FPS limit).
     
    Last edited: Aug 11, 2019
    Coanda likes this.
  6. So set it to 0 will decrease the input lag and eat more FPS and vice versa?
     
  7. unknwn

    unknwn Alien

    In theory yes, however I have no evidence that it actually reduces the input lag.:)
     
    After_Midnight likes this.
  8. At my system I need all FPS I can get :D
     
  9. Shooter80

    Shooter80 Racer

    I like it. I put that r.OneFrameThreadLag=0 (and RHI.MaximumFrameLatency=1) in my Engine.ini* and my Max CPU/Thread usage in a low populated server went from around 50% to 65%.

    I can't say for sure that there is any less input lag, but I'm still above the 90fps I need for VR, so I'll just choose to believe there is one frame less lag, and leave it that way.

    Nice find, thanks for sharing.
     
  10. dek

    dek Racer

    Nice find mate. Will try out today evening and report.
     
  11. f_deutsch

    f_deutsch Hardcore Simmer

    Coanda likes this.
  12. Orcajavi

    Orcajavi Racer

    Interesting, where do I find the file to modify? What command should I enter exactly? Thank you
     
  13. Coanda

    Coanda Alien

    like so...

    C:\Users\xxx\AppData\Local\AC2\Saved\Config\WindowsNoEditor\Engine.ini

    [SystemSettings]
    r.OneFrameThreadLag=1
     
    Orcajavi likes this.
  14. Shooter80

    Shooter80 Racer

    Ok, I take that back...

    It was fine when there was only a few cars in a server, but handily 15mins before my league race last night I joined a server with 26 cars in it for a quick warm up and the performance was terrible. Max CPU/Thread usage was never above about 70% but the performance was pretty much undrivable (down at 45FPS+ASW, I think sometimes even below that). I jumped out, removed the setting(s*) from the Engine.ini and then did a whole race with 26 cars without a single problem or ever noticeably dropping below 90fps.

    *Perhaps it was conflicting with some other settings that I'd added at the same time, so I'll need to test more to be certain, but I'll avoid this one for now.

    Don't add this (or anything to your Engine.ini) unless you are sure you will remember to try removing it again if you have problems down the line.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice