1. Do you need support for Assetto Corsa Competizione? Please use the proper forum below and ALWAYS zip and attach the WHOLE "Logs" folder in your c:\users\*youruser*\AppData\Local\AC2\Saved. The "AppData" folder is hidden by default, check "Hidden items" in your Windows view properties. If you report a crash, ALWAYS zip and attach the WHOLE "Crashes" folder in the same directory.
  2. FOR ASSETTO CORSA COMPETIZIONE: If you report issues with saved games, please always zip and attach your entire User/Documents/Assetto Corsa Competizione/Savegame folder!
  3. If your game executable is missing, please add your entire Steam directory to the exceptions in your antivirus software, then run a Steam integrity check or reinstall the game altogether.

[NOT ACC's FAULT!] Severe Stutter with Non-synced FPS

Discussion in 'ACC General Discussions' started by LeDude83, Apr 12, 2019.

  1. LeDude83

    LeDude83 Alien

    Hello guys,

    I've had this for a very long time, now: when I run any game without either VSync or FreeSync, the image looks absolutely terrible because of strong stutter. This is not an ACC issue, I get the same also with World of Tanks. It's something in my system.

    Since the image is really good and smooth with FreeSync on, I never bothered too much. But I'd like to get to the bottom of it. Please look at this video and let me know what you think:



    IDK why the quality is so bad but you can still see the stuttering. The FPS were well above 90, all the time. Refresh rate of monitor is 75.

    Things I have already tested:

    - Use an NVIDIA RTX2070 - no difference
    - Connect monitor with HDMI instead of DP - no difference
    - Connect a different monitor - no difference
    - HPET on/off - no difference

    Cheers
     

  2. Similar Threads
    Forum Title Date
    Troubleshooting - Workarounds [NOT A BUG!] CPU / GPU Bottleneck Dec 16, 2017
    Graphics and Models/Tracks Bugs & Issues [not such bug or issue] "back plate miura sv" and "more than 24 skins" Nov 24, 2015
    Chit Chat Room [existing licenses] which cars should be in kunos' todo list? [not a request thread] Feb 25, 2015
    Programming Language - Apps - GUI Themes [not completely solved] memory conflict while using "functools.partial" Jan 15, 2015
    Troubleshooting - Workarounds [not yet implemented on all cars] activating headlights doesn't work properly May 14, 2014
    Multiplayer Bugs & Issues Lotus Exos 125 s1 skin change on multiplayer [Nothing Special!] May 9, 2014

  3. mikendrix

    mikendrix Simracer

    I am mostly on VR but I play sometimes with my old 24’ screen.
    I also had some of these in the background, when I turn.
    My screen is 60Hz, and my average fps is 70.
    So I just set the frame limit to 60, and activate vsync.
    Now it’s smooth.
    I hope it’s as simple as that for you to solve this problem.
     
  4. LeDude83

    LeDude83 Alien

    Thank you for your reply.

    I can reassure you - like I said before, the image is very smooth when I activate FreeSync. I also cap the FPS at 74 with RTSS - I read that this is the limiter with the lowest additional latency.

    I'm just curious to understand why I get this ridiculous stutter when I have no sort of syncing activated and are above the refresh rate. Shouldn't there be screen tearing but a smooth image?!?
     
  5. Luis Branco

    Luis Branco Hardcore Simmer

    Usually, when I have any issues with my PC, I first look to the PSU.
    Over the years I had experienced 3 different graphic issues, and all were due to PSU failure/connection.

    One was simply that I didn’t connected one of the PCIE power cables firmly and it was somehow lose, to the point that, when playing games, sometimes the image froze and I would have to force a restart.
    I solved it by plugging the cable firmly to the card.

    The other was the PSU fault, because the voltage that was going to the graphic card was fluctuating intensively. Sometimes were good as it should but others dropped immensely and the image would either stutter or just froze completely. I've noticed it only by chance, because, after trying so many things, turned on the card monitor log save and in there it showed the high fluctuation of the power used by the card.
    I solved it by changing the PSU.

    The third, the PSU didn't have any failure but the power delivered to the graphic card was below the recommended with that PSU. The frame rate was very irregular and sometimes it would stutter massively.
    The solution was to change for a PSU with a higher power output.

    To start with, I would check if all is fine with the power supply.
     
  6. LeDude83

    LeDude83 Alien

    Ok thanks. The PSU is 750 W so it should be fine, basically.

    The power cables are properly attached, I checked that.

    I will look at a detailed graph of the power consumption to check for fluctuation as you described.
     
  7. PhilS13

    PhilS13 Alien

    This is windows triple buffering in action. You are dropping a frame (FPS-refresh rate) times per second.
     
    Olivier Boissel and LeDude83 like this.
  8. LeDude83

    LeDude83 Alien

    Erm ok...and how should I verify this claim, please?
     
  9. PhilS13

    PhilS13 Alien

    Cap FPS in game to 76.

    Use F7 freecam and move laterally in a pitlane. It will be obvious that you "skip" a frame every second, while getting no tears.

    If that is the case, you are somehow running in the windows triple buffered vsync mode or an equivalent mode on your GPU (Nvidia calls it fast sync iirc, you said you tested another GPU so that is unlikely).
     
  10. warth0g

    warth0g Simracer

    Don’t mean to hijack the thread, but I’m a bit clueless about all of this frame rate etc stuff. I just got a new monitor which is a 144hz one. It seems fine out of the box, but I’m not sure if I should be fiddling with freesync (I really don’t understand what that means) or locking the framerate to 144 or whatever. Like I said, clueless! Any advice for ultimate quality please? I have a 1080ti is that matters....
     
  11. LeDude83

    LeDude83 Alien

    I think you are right - it makes perfect sense. I'll test that later and check the driver for those settings. I'll also test between different window modes and look for the "Fullscreen Optimizations" in Win10. I read that the only way to defeat this sort of buffering is to run in exclusive fullscreen mode.

    Please open your own thread. I'll gladly help you there.
     
  12. dek

    dek Racer

    No stutters in AC, PC2 or RF2. Last one is also very demanding on the CPU.
     
  13. f_deutsch

    f_deutsch Hardcore Simmer

    A bit off your original topic. For almost 0 latency I recommend use RTSS "scanline sync" instead of "framerate" limit and limit fps on ACC.

    On topic. Can you activate the fsp counter of ACC just to get an idea of how they are? Unfortunately to me the first part of the video looks blurry and then gets better near the end. It looks similar to me when I activate adaptive sync.
     
    LeDude83 likes this.
  14. LeDude83

    LeDude83 Alien

    Yes! I tested it just like you said. It's enough if I just swerve left-right to see it clearly: each second, there's one skipped frame. When I set the cap to 77 it's twice a second. There was no tearing.

    So I'm very happy that nothing is "broken". In the meantime I tried a lot of different settings, aiming to deactivate all sorts of syncing but with no success. I can't get "normal, free-running FPS" on my PC. Maybe it's a WIN10 thing...dunno. I just wonder how the people here saying to run non-capped FPS do it.I have a hard time imagining that someone could drive with such a horrible image.

    Anyways...FreeSync is back on and the image is smooth, again (except for the stutter I mentioned in my other thread).
     
    PhilS13 likes this.
  15. PhilS13

    PhilS13 Alien

    On windows 10 here I was able to get it. That was few months ago before having GSYNC monitor so it's a IIRC :

    Windows GameBar mode thingy needs to be off.
    Need to right click on ac2-win64-shipping.exe and disable fullscreen optimization.
    The game needs to run in fullscreen mode.

    Then you should get true no sync exclusive fullscreen.
     
  16. DuckeyTapey

    DuckeyTapey Hardcore Simmer

    That's pretty much what I have. I might have also disabled GameBar and fullscreen optimization related things in the registry a while back to make sure they're off globally, but shouldn't be necessary I guess. Games run uncapped with tearing but without this type of stutter.
     
    Atak_Kat and LeDude83 like this.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice