1. Do you need support for Assetto Corsa Competizione? Please use the proper forum below and ALWAYS zip and attach the WHOLE "Logs" folder in your c:\users\*youruser*\AppData\Local\AC2\Saved. The "AppData" folder is hidden by default, check "Hidden items" in your Windows view properties. If you report a crash, ALWAYS zip and attach the WHOLE "Crashes" folder in the same directory.
  2. FOR ASSETTO CORSA COMPETIZIONE: If you report issues with saved games, please always zip and attach your entire User/Documents/Assetto Corsa Competizione/Savegame folder!
  3. If your game executable is missing, please add your entire Steam directory to the exceptions in your antivirus software, then run a Steam integrity check or reinstall the game altogether.

"Public beta" 1.0.5 - UPDATED to Live!

Discussion in 'ACC General Discussions' started by pankykapus, Jul 2, 2019.

Thread Status:
Not open for further replies.
  1. Coanda

    Coanda Alien

    hopefully Minolin sets the record straight here...
     
    romandevision and sps_for_race like this.
  2. m_box97

    m_box97 Racer

    @Coanda I'm not 100% shure but going to the pits might be instantaneous, in that case it might be good practice to teleport to the box before quitting/restarting
     
    romandevision and Coanda like this.
  3. Rolz

    Rolz Alien

    solid crash with most recent beta release
     

    Attached Files:

  4. GoBo

    GoBo Gamer

    Oh c'mon man, moving the player location to box after disconnection should be something done from code, not by the player. When someones lost its connections doesn't have the choose to go back to boxes before being disconneced. Even if the players reconnect shoul'd start from boxes.

    Thist little change would be a great save of time and annoyances for thousands of people and i'm pretty confident that there are only to modify a few lines of code.
    Coanda, sorry but... I told you so! Don't quit your races if you want to keep your SA!
     
    romandevision likes this.
  5. Coanda

    Coanda Alien

    Did you... I honestly cant remember. So many posts to keep track of matey. If you can drop us a link to refresh my memory :) The issue is not keeping points gained for the session. The issue is you can be hit by the Ai after you restart a race for a period of 2-3 seconds thats why @m_box97 made the suggestion to transport to the pits first then restart so you do not get this 3 second period which can cause carnage and SA deductions with the Ai.
     
    GoBo likes this.
  6. Coanda

    Coanda Alien

    I remember the conversation now...
     
    GoBo likes this.
  7. Minolin

    Minolin Staff Member KS Dev Team

    wait wait wait.. first, this isn't a 1.0.5 issue.
    Then most of what I read is between "technically wrong" or "doesn't make too much sense".

    You say we see collisions happening while the pause menu is up? That's something interesting, I'll try to reproduce it - thanks.
    Then we have the impression that a restart (and the corresponding teleports) may cause collisions in SP; I'll have a look here as well. Though teleports are already handled well, but I'll see if there is something to do. Technically the collisions happen in the physics world, and the physics doesn't know anything about SA, sessions, teleports and so forth. That's why we have to look at collision reports in a specific way, and decide what to ignore. Sadly the nature of multithreading and timing doesn't exactly make this 100% easy, so it's quite possible that there is something to improve.
     
  8. sps_for_race

    sps_for_race Simracer

    Is that really true or speculation for the loss of SA.
     
  9. m_box97

    m_box97 Racer

    I was talking about singleplayer so no connection to lose, in multyplayer you must stop the car to access the menu and you should do that in a safe place. If you lose connection in MP the car disappears, not sure what you are talking about.

    @Minolin not while the menu is up but after you click on restart/quit the ACC logo appears but in the background you still hear the game running and if you hit a car during that period it seems to count the collision in your SA rating. After a couple of seconds the game correctly teleports you to the start (or quits) without problem (teleporting is fine in my experience)
     
    Last edited: Jul 4, 2019
    Coanda and sps_for_race like this.
  10. Minolin

    Minolin Staff Member KS Dev Team

    mh ya that matches my expectation, teleports are specifically handled and shouldn't ever lead to SA relevant collisions
     
    m_box97 likes this.
  11. Coanda

    Coanda Alien

    No issues whilst paused. I have heard carnage after restarts within that 2-3 second phase. So if I understand this correctly you are saying this should not impact your SA. Minolin how do you explain the 9 OBWP I received ("Public beta" 1.0.5 - UPDATED to build 3974835, UPDATED to build 3977768) ?

    1000% I never hit any Ai. I cant say 100% sure for the 2-3 second restart phase though. I did not hear anything (i have in the past) however it may have occurred as there were 2 Ai cars roughly 50-100m behind me. Can your logs see where and what caused the deduction?
     
    Last edited: Jul 4, 2019
  12. Coanda

    Coanda Alien

    Only going by sound and a weird result on my SA report.
     
    sps_for_race likes this.
  13. Coanda

    Coanda Alien

  14. pankykapus

    pankykapus KS Dev Team Staff Member KS Dev Team

    There is an update that fixes the CP server weather issue globally. This build is now also on the Live branch. Closing thread as now we're synced up.

    Thank you everyone for your reports, it was very useful.
     
    vanveen, Tundra, Luca Zari and 6 others like this.
Similar Threads
Forum Title Date
ACC General Discussions "Public Beta" 1.0.7 - Preview 3 - HOTFIX IS NOW LIVE! Aug 8, 2019
ACC General Discussions "Public Beta" 1.0.7 - Preview 2 Aug 7, 2019
ACC Gameplay Steering Misalignment Disappears After Loading Save [1.0.7 public beta] Aug 2, 2019
ACC Controls & Peripherals Cannot bind gear up/down to keyboard keys while using wheel steering v1.0.7 public beta 2/8 Aug 2, 2019
ACC General Discussions "Public Beta" 1.0.7 Jul 31, 2019
ACC Multiplayer "Public Beta" parts in 1.0.6 Jul 12, 2019
ACC Troubleshooting V 1.0.5 the latest public beta continuous crashing on MP Jul 5, 2019
ACC General Discussions "Public beta" 1.0.5 build 3963945 Jun 29, 2019
ACC General Discussions "Public beta" 1.0.5 build 3952167 Jun 25, 2019
ACC General Discussions "Public beta" 1.0.5 Jun 19, 2019
ACC Troubleshooting 1.0.4/public beta, game freezes after quitting sp session Jun 18, 2019
ACC Troubleshooting Public Beta 1.04 - Crash D3D device being lost Jun 17, 2019
ACC General Discussions Re : "Public beta" 1.0.4 - now also LIVE! Jun 15, 2019
ACC General Discussions "Public beta" 1.0.4 - now also LIVE! Jun 14, 2019
ACC General Discussions "Public beta" 1.0.3 - v2 Jun 12, 2019

Thread Status:
Not open for further replies.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice