1. Do you need support for Assetto Corsa Competizione? Please use the proper forum below and ALWAYS zip and attach the WHOLE "Logs" folder in your c:\users\*youruser*\AppData\Local\AC2\Saved. The "AppData" folder is hidden by default, check "Hidden items" in your Windows view properties. If you report a crash, ALWAYS zip and attach the WHOLE "Crashes" folder in the same directory.
  2. FOR ASSETTO CORSA COMPETIZIONE: If you report issues with saved games, please always zip and attach your entire User/Documents/Assetto Corsa Competizione/Savegame folder!
  3. If your game executable is missing, please add your entire Steam directory to the exceptions in your antivirus software, then run a Steam integrity check or reinstall the game altogether.

What the heck is going on?...wheel and controller settings misbehaving using Content Manager

Discussion in 'Chit Chat Room' started by Ray Lord, Jan 1, 2020.

  1. Ray Lord

    Ray Lord Rookie

    My set up has been working fine up until a day or two ago. When I open the game using Content Manager (as I have a lot of mods) I can't use controller presets I've always used. When I try to create a fresh one, my wheel is not recognised and switches I've used on by DSD button boxes cause all kinds of weird, unintended actions that I have not programmed.

    my set up: Fanatec Elite wheel base for PS4 and Fanatec GT3 wheel. Using latest Sol and v 128 of Shaders patch. Have always used Joy to Key to use my button boxes. I've always started up my wheel before opening Steam and AC using CM.

    Actions taken so far:
    - I've checked game file integrity using the Steam tool several times
    - tried different USB ports on my hi-end Alienware PC. The usual ones have always worked
    - uninstalled and reinstalled my Fanatec drivers
    - reluctantly decided to uninstall and reinstall of AC via Steam. Backed up game files before hand as I have lots and lots of mods and time spent enhancing game content.
    - even though I've not used it for over a year, I tried using the old stock AC launcher before restoring all my game files. Game seems to load controller settings and I can create a preset.
    - tried CM again...still no good. Can't create a new preset. CM sees the button boxes but not my Fanatec wheel.
    - deleted the contents of App data/local/AcToolsContent Manager/presets
    - reconnected to a new copy of CM - standard version. Can set some controller settings but some still misbehave. Upgraded to the full version of CM. Still not right.
    - poked around the web for anything I could try/change in the Steam interface under game controllers

    This is really frustrating as I've never had controller issues before and I spend most of my time driving AC. Anyone experiencing these "NEW" controller issues? Some strange conflict due to a recent Steam/ Windows 10 upgrade? I've spent big bucks on many paid mods for AC and am determined to figure this out.
     

  2. Similar Threads
    Forum Title Date
    ACC Troubleshooting SIM has some Freezes problems going on, tech questions to check. Aug 6, 2019
    Chit Chat Room What in the heck is going on here? Dec 27, 2013
    Troubleshooting - Workarounds X-bow R checksum mismatch since 1.16.4 Aug 18, 2020
    Troubleshooting - Workarounds Checksum Error When Friends Join My Server But Only With Kunos Content Feb 29, 2020
    ACC User Interface Check/uncheck in the MFD and open multiplayer chat Feb 11, 2020
    ACC Graphics - Tracks and Cars [1.3] Checkered Flag Feb 5, 2020
    Chit Chat Room Suspension runs out to bump stop, and car bottoming; which app to check them? Jan 27, 2020
    Screens & Videos Drifting Full Throttle Skyline R32 Check it out Dec 12, 2019
    ACC Troubleshooting Change tyres checkbox was greyed out, at to pit multiple times to have tyre changed... Nov 23, 2019
    ACC Gameplay No checkered flag in SPA Nov 18, 2019
    ACC Gameplay checkered flag waved too early Nov 14, 2019
    ACC Gameplay Anyway to select pitsto checkmarks? Aug 4, 2019
    ACC User Interface No way to check if PIT LANE SPEED is active (in external cameras) Jun 11, 2019
    Multiplayer Bugs & Issues RESPONSE: ERROR,INVALID SERVER,CHECK YOUR PORT FORWARDING SETTINGS May 28, 2019
    ACC User Interface Please add throttle travel check like in AC May 27, 2019

  3. André57

    André57 Racer

    Hi,
    It may sound strange but in my experience sometime regarding a problem from opposite angle help to find solution, so my set-up is fairly unusual my wheel is too old for preset and my pedals are flight sim controller. As AC is flexible to accept this odd couple, my suggestion is: try to set up your devices without preset I mean manually. It work for me and I have done this only once when I start to use AC and again when I install CM. So far it is pretty simple and never failed. Basically I only have to start my wheel before lunching AC via CM and everything work fine. I must add that I recently build a new system around a Rysen CPU and once again I manually set up my wheel and pedals and it still work. hope it can help, good luck.
     
  4. Cote Dazur

    Cote Dazur Alien

    @Ray Lord same here, if I have my Xbox controller connected (for oculus) then the Xbox take the place of my h-shifter, if I do not connect the Xbox controller everything is fine.
     
  5. docfar

    docfar Rookie

    Funny I just went through this nightmare - I have a P1 and P2 and a Fanatec DD1.
    I can get it working on AC with CM but no luck with ACC

    Basically I start CM with the DD not connected - CM then sres the 2 boxes as separate controllers. Then you plug in the wheel.

    However I had to remove the bindings, restart the PC a couple of times to make sure the controllers are all indexed correctly (so all controllers plugged in and on and in the same USB ports - you cannot change ports once you have set your bindings). Once I am happy that CM is showing the controllers in the same order each time I go in and program the bindings and save the profile in CM.
    If you change rims you need to load the new rim settings in CM and then close CM and restart it with the wheel off. Then plug in your wheel.
    I hope I explained this convoluted workaround in a manner that is understood!
    PM me if not
     
  6. Typer

    Typer Simracer

    Yeah CM sometimes hoses my Fanatec controls setup. I have to reconfigure it through the AC wizard to get it working again.


    Sent from my iPad using Tapatalk
     
  7. Hi!! I have the exact same problem and this is driving me nuts...

    I think I understood your instructions... basically verified that the PC index correctly the usb controllers... then what I did was:

    - Open CM with the base off and the wheel not installed... I have Heuskinveld pedals, so I connected tehm while CM was running.
    - Clear ALL the bindings I had in CM.
    - Turned on the dd1 base.
    - Assigned the axis. Assigned the pedals.
    - Connected the wheel (Mclaren GT3)
    - Assigned the buttons
    - Save the profile... and right then I went back and the Axis was not responding.
    - Assigned the axis again, went back to the buttons and they were not responding.. I mean.. I clicked on them and saw them turn on and off in the CM indicator to the right of the screen (red dot), but not on the assigned function box.

    Can you please tell me what I'm doing different from what you did to get this going? I really appreciate your help. This seems to be the only thread on this on the internet.. LOL

    Best regards,

    Chale
     
  8. KoAStR

    KoAStR Rookie

    I just ran into this and was only able to fix it by disabling controller support in steam general controller settings.

    If I have controller configuration support enabled in steam general controller settings, where you can configure controller options per game, I have to set steam properties, input per game to "force off" for driving games else the wheel doesn't respond - just as it wasn't responding when launching AC via CM. So it seems to me that launching from CM bypasses/ignores this steam setting and launches default input, where if controller configuration support is enabled is forcing the controller to override the wheel.

    Hope that helps.
     
    Last edited: May 10, 2020
  9. tsmith154

    tsmith154 Rookie

    This very interesting. So I'm not alone. This is my situation. I only have one controller connected to my computer and AC sees my controller. I bind everything and everything works. Now I don't want my controller always connected to my computer I use it for other things. So I turn off my computer unplug the USB for my steering wheel then turn my computer on. Ok, now I use my computer for other stuff. After that I turn my computer off and plug in my steering wheel into the same USB, that USB was not used for anything else while the steering wheel was unplugged. AC sees my controller, I know that because the area that shows all controllers has my steering wheel and when I turn the wheel the wheel is indicated it is being tuned. But when I try to drive AC nothing happens as if my controller is not recognized. If I go into settings Advanced and load my saved configuration then go to drive AC again nothing happens. Now if I rebind everything then yes AC actually uses my steering wheel to turn the car. If I never unplug my steering wheel ever then AC has not problem and uses my steering wheel.

    I can't just leave this steering wheel plugged in all the time and I sure don't want to have to rebind ever time. In the section that shows all the controllers recognized it always shows my steering wheel and other controllers that is not connected to my computer and never was. I don't know how to delete them.

    Any thought on this?
     
  10. tsmith154

    tsmith154 Rookie

    Wow. I rebound my controller just now and I use my clutch peddle as the hand break. I've used that in the past and now I bound the same way I did before and see it is being recognized, I have to use the check mark to reverse the direction But I go to drive AC shows no hand break action. My clutch peddle does nothing.

    I have TS - XW Racer Sparco P310 Competition Mod.
     
  11. FriendOfJah

    FriendOfJah Racer

    Hi Folks - I just received delivery of my new DSD Black Max II Button Controller. I got it all set up on desk with the RAM Mount and plugged it in. I went into ACC and tried to assign some functions to it. Nothing happens. I emailed DSD and got an insatnt response. I then used the debugging software from him, and sure enough, all of the buttons work fine. I went back into ACC to the Options/Controls. I noticed that in the Presets section, in addition to my Thomas Super Wheel, there was a DSD P-Series Controller. I clicked on it and clicked on load. When I did, the bindings to my Wheel were all lost. I clicked on the Ignition, pushed a button on the DSD box, nothing! What the heck? I'm pretty sure its plugged into a USB 2.0 port on my 6 month old high end PC with an ASUS Rog Strix motherboard. What am I supposed to do to get this box to work and get my wheel back?
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice